We’re currently experiencing problems on LIVE4.

Incident Report for Henry Schein One

Resolved

This incident has been resolved.
Posted 13 days ago. Mar 23, 2025 - 01:14 MDT

Investigating

We are currently investigating this issue.
Posted 13 days ago. Mar 23, 2025 - 01:14 MDT
This incident affected: Dentrix Ascend Availability.