We’re currently experiencing problems on LIVE2.

Incident Report for Henry Schein One

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 07:03 MDT

Investigating

We are currently investigating this issue.
Posted Apr 01, 2025 - 07:02 MDT
This incident affected: Dentrix Ascend Availability.