We’re currently experiencing problems on LIVE2.
Incident Report for Henry Schein One
Resolved
This incident has been resolved.
Posted Jul 21, 2024 - 01:01 MDT
Investigating
We are currently investigating this issue.
Posted Jul 21, 2024 - 01:00 MDT
This incident affected: Dentrix Ascend Availability.