We’re currently experiencing problems on SMILE.

Incident Report for Henry Schein One

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 10:43 MDT

Investigating

We are currently investigating this issue.
Posted Apr 01, 2025 - 10:42 MDT
This incident affected: Dentrix Ascend Availability.