We’re currently experiencing problems on LIVE3.

Incident Report for Henry Schein One

Resolved

This incident has been resolved.
Posted Mar 29, 2025 - 01:12 MDT

Investigating

We are currently investigating this issue.
Posted Mar 29, 2025 - 01:07 MDT
This incident affected: Dentrix Ascend Availability.