We’re currently experiencing problems on SMILE.

Incident Report for Henry Schein One

Resolved

This incident has been resolved.
Posted Feb 11, 2025 - 11:10 MST

Investigating

We are currently investigating this issue.
Posted Feb 11, 2025 - 11:10 MST
This incident affected: Dentrix Ascend Availability.