We’re currently experiencing problems on LIVE5.
Incident Report for Henry Schein One
Resolved
This incident has been resolved.
Posted Feb 10, 2024 - 01:45 MST
Investigating
We are currently investigating this issue.
Posted Feb 10, 2024 - 01:44 MST
This incident affected: Dentrix Ascend Availability.