We’re currently experiencing problems on LIVE6.
Incident Report for Henry Schein One
Resolved
This incident has been resolved.
Posted Feb 10, 2024 - 00:37 MST
Investigating
We are currently investigating this issue.
Posted Feb 10, 2024 - 00:36 MST
This incident affected: Dentrix Ascend Availability.