We’re currently experiencing problems on LIVE2.

Incident Report for Henry Schein One

Resolved

This incident has been resolved.
Posted Feb 08, 2025 - 23:51 MST

Investigating

We are currently investigating this issue.
Posted Feb 08, 2025 - 23:50 MST
This incident affected: Dentrix Ascend Availability.