We’re currently experiencing problems on LIVE19.
Incident Report for Henry Schein One
Resolved
This incident has been resolved.
Posted Feb 14, 2024 - 17:11 MST
Investigating
We are currently investigating this issue.
Posted Feb 14, 2024 - 17:10 MST
This incident affected: Dentrix Ascend Availability.