We’re currently experiencing problems on LIVE4.

Incident Report for Henry Schein One

Resolved

This incident has been resolved.
Posted Feb 16, 2025 - 00:11 MST

Investigating

We are currently investigating this issue.
Posted Feb 16, 2025 - 00:10 MST
This incident affected: Dentrix Ascend Availability.