We’re currently experiencing problems on LIVE3.

Incident Report for Henry Schein One

Resolved

This incident has been resolved.
Posted Feb 16, 2025 - 01:25 MST

Investigating

We are currently investigating this issue.
Posted Feb 16, 2025 - 01:23 MST
This incident affected: Dentrix Ascend Availability.