We’re currently experiencing problems on LIVE4.

Incident Report for Henry Schein One

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 09:23 MDT

Investigating

We are currently investigating this issue.
Posted Apr 01, 2025 - 09:22 MDT
This incident affected: Dentrix Ascend Availability.